Overblog Suivre ce blog
Editer l'article Administration Créer mon blog

Ha algum tempo, quiz utilisar "Excel" (Microsoft) para fazer uma pequena base de dados dalguns batismos.
Mas, como Excel so conhece as datas desde 1900 (1904 para algumas versões), impossivel de utilisar as datas que la escrevia. Nem podia classificar os batismos por ordem cronologica, nem fazer qualquer calculo.

Dei uma volta por Internet antes de me enervar completamente... Eis aqui o resultado. ;-)
Aconselharam o pequeno programa "Xdate", mas não achei isso muito convincente.
Num forum encontrei esta formula :
 

=SI(ESTNUM(C2);CNUM(TEXTE(C2;"aaaammjj"));CNUM(STXT(C2;7;4)&STXT(C2;4;2)&STXT(C2;1;2)))

 

 


Tive de a modificar (tinha um erro) e adaptei-la ao meu proprio quadro, depois de ter compreendido como ela funcionava. Se quiser adapta-la, afinal não é muito complicado...

E uma formula que escrevo numa coluna que não imprimo, e que reduzo o mais possivel no quadro, para não se ver muito. Essa coluna so serve para fazer calculos ou para classificar cronologicamente.

Tem aqui um exemplo de como se apresenta :

 

 

 

 

 

  A B C D
1 Formula Nome Batismo Local
2 =... João 12/03/1678 Lisboa
3 =... Maria 03/05/1749 Porto
4 =... Manuel 24/02/1785 Guarda


Eu pus a formula na coluna "A". As datas de batismo na coluna "C".
Antes de escrever alguma data, tem de modificar o "formato" da "cellule" (não conheço o terma português) de "standard" para "texto". Isso vai essencialmente ser importante se você também mistura datas posteriores a 1900.


Cuidado !!! é muito importante escrever as datas deste modo : 12/03/1678 e não : 12/3/1678 !!!


A formula que puz em A2 diz (em português normal) :

O que esta na "cellule" C2 (aqui "12/03/1678") é uma data escrita da maneira "aaaammjj" (quer seja: 16780312).
Para escrever esse numero (16780312) que vai servir para os calculos, procure em C2 o 7° caracter e escreva os 4 caracteres a partir dai (STXT(C2;7;4)). Isto é o ano.
Depois procure em C2 o 4° caracter e escreva os 2 caracteres a partir dai (STXT(C2;4;2)). Isto é o mês.
Enfim, procure em C2 o 1° caracter e escreva os 2 caracteres a partir dai (STXT(C2;1;2)). Isto é o dia.


A unica coisa que você pode modificar é o nome da coluna onde estão as suas datas (por exemplo substituir todos os C2 por E2).
(Não sei se nos computadores portugueses não deve substituir o "=SI" por "=SE" ? e as outras palavras em francês "EST" por  "E", "TEXTE" por "TEXTO"; ou se Excel reconhece a formula francesa)


Por enquanto é o método mais eficaz que encontrei...

 

 

Tag(s) : #Genealogia

Partager cet article

Repost 0